What's new

[SOLVED] [Win8.1Pro N] Audio lat. issues (High exec. time of NDIS). FIX: FORMAT/UPGRADE TO 10

Joined
Oct 5, 2017
Messages
19
I've been getting glitchy/digitized audio on and off, mainly from youtube but occasionally from other audio sources as well.

CBS.zip and other relevant files are on my Google Drive

Prior to creating this post (and my first exposure to this forum), I followed Xilolee's steps from this post with the exception of defrag because I have SSDs. I'll defrag them if instructed. I sadly don't have much more information than this. I've checked drivers, nothing seems wrong in device manager, and there doesn't seem to be a direct cause as to what makes ndis.sys suddenly very slow, but I only get the audio issues when it's slow and it appears to only be slow when I get the audio issues.
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Just as further information, I ended up formatting and reinstalling Windows. The problem disappeared for a few days but is now back just as bad as before.
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Note: It looks like you can no longer use the command as "xperf <trace file>" and need to use "wpa <trace file>" instead. Likewise, There is no "DPC CPU" graph as near as I can find, merely a "DPC/ISR" graph found by expanding "CPU Usage (Precise)"

Those instructions showed that ndis.sys was the longest running, with tcpip.sys not far behind. The reference table says those are both handled by Windows Update, I had no important updates but I installed the 4 optional (but non-preview) updates that were listed.

The problem persists.
 

axe0

Forum Moderator, BSOD Kernel Dump Expert, Contributor
Staff member
Joined
May 21, 2015
Messages
756
Location
The Netherlands
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Windows drivers aren't the cause, something else is. Provide the requested data please.
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Sorry, the Windows 8.1 page didn't continue with the additional information needed so I missed that part. Here it is:


  • System Manufacturer? Custom built
  • Laptop or Desktop? Desktop
  • Exact model number (if laptop, check label on bottom) N/A
  • OS ? (Windows 10, 8.1, 8, 7, Vista) Windows 8.1 Pro N
  • x86 (32bit) or x64 (64bit)? x64
  • Service pack? 8.1
  • What was original installed OS on system? Windows 7
  • Is the OS an OEM version (came pre-installed on system) or full retail version (YOU purchased it from retailer)? Retail
  • Age of system? (hardware) Ranging from 6 years (Motherboard, CPU, C: drive) to a few months (the other 8GB of RAM most recently added)
  • Age of OS installation? Less than a week, prior to that maybe a few months to a year
  • Have you re-installed the OS? yes
  • CPU - i5 2500k
  • RAM (brand, EXACT model, what slots are you using?) 2x4GB Kingston 9905584-015.A00LF (Slots 1 & 3) and 2x4GB Patriot PSD34G 16002 (Slots 2 & 4)
  • Video Card - EVGA GTX 980 Hybrid
  • MotherBoard - (if NOT a laptop) - Asrock Extreme 3 Gen 3
  • Power Supply - brand & wattage (if laptop, skip this one) Kingwin Lazer Platinum 750W
  • Is driver verifier enabled or disabled? Disabled
  • What security software are you using? (Firewall, antivirus, antimalware, antispyware, and so forth) Zone Alarm free firewall, Windows Defender for antivirus
  • Are you using proxy, vpn, ipfilters or similar software? No
  • Are you using Disk Image tools? (like daemon tools, alcohol 52% or 120%, virtual CloneDrive, roxio software) Alcohol 120 was installed, hasn't been reinstalled since windows was reinstalled
  • Are you currently under/overclocking? Are there overclocking software installed on your system? Overclocking (4.5 GHz), no software installed
Speccy Info - http://speccy.piriform.com/results/pnlcGU6iujjYRjFj2zuKWbY

dxdiag and msinfo files (same link as first post) - SysNative Files - Google Drive
 

axe0

Forum Moderator, BSOD Kernel Dump Expert, Contributor
Staff member
Joined
May 21, 2015
Messages
756
Location
The Netherlands
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Please also follow the WPA instructions in the link in my previous post.
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Sorry, the 8.1 instructions have you check the graphs yourself and then delete the trace instead of uploading it. It's been added to the Drive folder. Here's the link again.

SysNative Files - Google Drive
 

axe0

Forum Moderator, BSOD Kernel Dump Expert, Contributor
Staff member
Joined
May 21, 2015
Messages
756
Location
The Netherlands
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

It looks to me like the issue is coming from your network drivers.

Assuming you're using the TP-Link PCIe adapter, have you
- checked for driver updates,
- reinstalled the drivers,
- reseated / tested in a different slot?
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

I've checked for updates and reinstalled the drivers, both what TP-Link provides and what I can find for the Qualcomm Atheros chip itself, neither did anything. I'll try moving the adapter to a different slot.
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Ok, so my GPU blocks the other PCI port, I have a PCI-E 3 port open, but moving the GPU to there gets the PC stuck at the blue logo when booting and putting the adapter in there, neither Windows nor the TP Link utility detect the card. I'm thinking that second PCI-E port must be bad, I've literally never used it before though so I don't know.

Long story short, I'm not able to try the wireless adapter in another slot without buying a new motherboard.
 

axe0

Forum Moderator, BSOD Kernel Dump Expert, Contributor
Staff member
Joined
May 21, 2015
Messages
756
Location
The Netherlands
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Have you tried the by Windows Update provided drivers?
 

axe0

Forum Moderator, BSOD Kernel Dump Expert, Contributor
Staff member
Joined
May 21, 2015
Messages
756
Location
The Netherlands
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

I meant uninstall the drivers of TP-Link, rebooting and checking for updates.
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

I uninstalled the TP Link drivers and rebooted, windows installed something, the adapter functions but the problem persists. I checked Windows Update itself for good measure and all that's pending is a Defender definitions update.
 

axe0

Forum Moderator, BSOD Kernel Dump Expert, Contributor
Staff member
Joined
May 21, 2015
Messages
756
Location
The Netherlands
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Any chance you have a cable for your display that fits in a motherboard video port?
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Sure, should I just disconnect all my monitors and then pick one and hook it directly to the motherboard?
 

axe0

Forum Moderator, BSOD Kernel Dump Expert, Contributor
Staff member
Joined
May 21, 2015
Messages
756
Location
The Netherlands
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Yes, also remove the GPU, seat the network card into another slot and test it.
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Removed GPU entirely, moved adapter to other PCI slot, hooked one monitor to motherboard and left the rest unhooked. Computer boots but does not detect the adapter. I also tried running the TP Link driver installer and it didn't detect the adapter either.
 
Joined
Oct 5, 2017
Messages
19
Re: [Win8.1Pro N] Audio latency issues (High execution time of ndis.sys)

Further testing, I removed the adapter entirely (and put my GPU back in). I have a router running in bridge mode and then connected to my PC. So far ndis execution time is drastically improved, bandwidth is garbage though.
 
Top