1. #1

    Another Win 7 SP1 inst fail

    Boughta used laptop (PB Easynote TK) and solved some issues regardingtrojans etc.
    Wentthrough a lot of successful updates but ended up with the last one,Win 7 SP1 giving error code 80070490 at configuration afterinstall.
    Spentthe last two weeks trying to solve it and found Ben-IS solution here:http://social.technet.microsoft.com/Forums/windows/en-US/bfb3e5b5-a3bd-4124-b4d6-7fb437ac7b74/windows-7-errornotfound-0x80070490-while-trying-to-install-sp1?forum=w7itproinstallwhich basically pushes drivers found in CBS but not found in setupapi(in my case some 50+ drivers) into Driver Store.
    Itworked beautifully until pushing wudfusbcciddriver.inf_31bf3856ad364e35_6.1.7600.16385_none_be6ea1501b65c8c9(Filenot found).
    RunningSP1 installation again, still getting error code 80070490 and foundin CBSthatall drivers went through OK except wudfusbcciddriver.inf. Found alsothat the installation/configuration has been dealing withc09fb51818544c63,adc3e4acb1046b4b,c0797aa618703528and 5a3d703f5dc90ef8.
    However,when the configuration tries to open be6ea1501b65c8c9itcan't find it and neither can I.

    NowI'm fresh out of ideas. Can anyone push me into the correct directionfor progress?

    Attachment 7995

    • Ad Bot



  2. #2

    Re: Another Win 7 SP1 inst fail

    You are doing a great job helping people like me, I know you have a lot to do and I'm not in a hurry. So I just wait for my turn.
    In the mean time I try to learn as much as I can and will comment the progress here. It takes some time since I'm 60 years old and every bit I know about computers and software I've learned by myself out of pure curiosity.

    I have found the missing wudfusbcciddriver.inf_31bf3856ad364e35_6.1.7600.16385_none_be6ea1501b65c8c9 in the winsxs folder!
    I just wonder how I could miss it, I have been there looking a lot of times.
    Now I have to find out a correct way to get it into the repository folder without messing up any registers .....

    To be continued ....

  3. #3

    Re: Another Win 7 SP1 inst fail

    The "missing" folder is not found in the DriverStore or the Filrepository folders, only in winsxs folder.
    I can find it manually and the search ability from Start menu can find it.
    The security options on the folder is exactly the same as other successfully installed drivers.
    The SP1 installer can not find the folder since it's not in DriverStore.
    The pnputil command (pushing it from winsxs to DriverStore) can't find it in winsxs.

    Is it possible that any registers has been corrupted from one of the trojans I removed?

    Now I'm stuck again .....


  4. #4

    Re: Another Win 7 SP1 inst fail

    Forgot to mention a couple of things:
    Error code 80070490
    Running System Update Readiness Tool a number of times. Result: No errors detected
    Running sfc/scannow a number of times: Nothing wrong here either.

    Heard from a man from Scotland many years ago: Life is a ***** and sometimes you are married to it.....


  5. #5

    Re: Another Win 7 SP1 inst fail

    Yes, I am extremly persistent!

    Another 9 days has passed with a lot of thinking, trying, reading long Log reports etc.
    Tryied to download and install the SP1 ISO update from MS, same result...

    Suddenly found this part in one of the setupapi reports:
    'C:\Windows\winSxS\amd64_wudfusbcciddriver.inf_31bf3856ad364e35_6.1.7600.16385_none_be6ea1501b65c8c9\WUDFUsbccidDriver.inf'([strings])inf: Opened INF:'C:\Windows\inf\WINUSB.INF' ([strings])
    !!! sto: Driver package references a missing external file'C:\Windows\system32\drivers\winusb.sys'. Error = 0x00000002
    !!! sto: Failed to retrieve driver package copy files. Error = 0x00000002
    !!! sto: Failed to get list of driver package files. Error = 0x00000002, Filename =C:\Windows\winSxS\amd64_wudfusbcciddriver.inf_31bf3856ad364e35_6.1.7600.16385_none_be6ea1501b65c8c9\WUDFUsbccidDriver.inf
    sto: {Import DriverPackage: exit(0x00000002)} 10:58:00.193inf: Opened INF:'C:\Windows\winSxS\amd64_wudfusbcciddriver.inf_31bf3856ad364e35_6.1.7600.16385_none_be6ea1501b65c8c9\WUDFUsbccidDriver.inf'([strings])! inf: Add to Driver Store unsuccessful

    I have confirmed that the winusb.sys is missing in C:\Windows\system32\drivers\ so the laptop is telling the truth (as usual.....).

    I can only find that I have the last couple of weeks been looking intensively for a problem with wudfusbcciddriver and/or a registry problem when it all comes down to a missing file ... (sigh.)
    Now I am concentrating on how to install the winusb.sys in the correct folder and in the correct way (with the option that the wudfusbcciddriver and/or the winusb.inf is corrupted)..

    Any ideas on how, anyone?

  6. #6

    Re: Another Win 7 SP1 inst fail

    Next report of "progress":

    Asked a lot of people how to correctly install winusb.sys. Everyone answered that the only possibility is to reinstall Win7 according to mfr description.
    Foolishly I followed their recommendation....

    After several hours of backup:ing started the re-installation. The result came after restart, during "starting services", the information came up that the installation has failed and will continue after restart. Restarting and during "starting services", the information came up that the installation has failed and will continue after restart..... etc.

    Tried to start Win7 in safe mode and got the answer "installation can't continue in safe mode. Installation will continue after restart". And there I am again....

    So now i am sitting with a laptop I can't get in to (I'm writing this on another PC).
    I am an extremly patient man but this is beginning to get into my nerves ....

  7. #7

    Re: Another Win 7 SP1 inst fail

    Finally ....
    .... solved !!!

    After coming home I started with some hassle the repair disc and made a clear install (a system reset only did'nt work). Now I know first hand how extremly important it is to create the repair disc at an early stage.

    After stopping all automatic updates I ran the SP1 update (saved earlier as an ISO-file) and it updated without any glitch or special arrangements (see post #1).

    Obviously something happens during all previous updates (or program installations) to upset the SP1 update. What, how and why I have not the slightest clue and will not pursue the reason. Maybe someone will find the reason in the future but right now I'm proud of getting this solved by myself, almost not knowing what I am doing.

    But one thing is for sure: I had no chance doing this without all the tips and tricks you have described at this forum!! And I have learned a ton of new things!!!
    Many thanks and I really hope all your exams goes well. YOU'RE WORTH IT !!

    I sincerely hope you keep on with this forum, you are the best !


Similar Threads

  1. [SOLVED] All Windows Updates Fail To Install
    By war59312 in forum Windows Update
    Replies: 44
    Last Post: 12-16-2014, 02:34 AM
  2. windows update fail
    By Wasyl in forum Windows Update
    Replies: 0
    Last Post: 05-04-2014, 11:47 AM
  3. Will Windows 8 Fail?
    By zigzag3143 in forum Microsoft News
    Replies: 2
    Last Post: 05-14-2012, 10:25 PM

Log in

Log in