1. #1

    Join Date
    Nov 2018
    Location
    Germany - Wuppertal
    Posts
    6

    Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    Hello dear forum members!

    I seek your wisdom regarding a problem which leaves me in a bit of a hassle..
    Some time ago i set up a Windows Server 2016 machine as Domain Controller. Now for quite som time i have errors with windows Updates and as i recently found out, also with installing new roles/features. My investigations lead me to thinking it has to do with faulty language pack installations on a multilanguage install (DELL OS) similar to this topic: Error 0x80073701 w/Windows Update & New Roles/Features Add (Win Server 2016)

    I will of course firstly go through the steps from the posting intructions, gather more information an will then post back here. Sadly i cannot restart the server now which sfc /scannow requests me to do.

    Thanks and have a good day,
    Koff
    - ​When life gives you lemons, make lemonade -


    • Ad Bot

      advertising
      Beep.

        
       

  2. #2

    Join Date
    Nov 2018
    Location
    Germany - Wuppertal
    Posts
    6

    Re: Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    Hello everyone,

    hope you had a good day so far!


    I ran through the posting instructions but the problem persists so here´my problem:

    It began with not beeing able to install a feature on a Server 2016 with AD role. I always got the error 0x80073701 when i tried. Also at some point Windows Updates stopped working with different errors. I did some research and found that there where some errors in the CBS log stating that sourcefiles in other languages (spanish and korean) where missing. After I proceeded through the steps of the posting instructions (No corruptions found running sfc /scannow, DISM was sompleted successfuly and SFCFIX did not find any errors), i´m at least again able to install Windows Updates. Also when I try to install a feature now, the error has changed to 0x800f081f saying that the source files cannot be found. I could set a source path now for the installation but I don´t know which one, the only threads i found where regarding a .net installation and how to install it bcs the source files are naturally not in the repository. I imagine that there´s something wrong because normally the role i want to install does not need a specific source.

    CBS Log:
    HiDrive


    Thank you very much in advance for any help =)
    - ​When life gives you lemons, make lemonade -

  3. #3
    Moderator
    BSOD Kernel Dump Analyst
    Windows Update Instructor
    softwaremaniac's Avatar
    Join Date
    Oct 2014
    Location
    Croatia
    Age
    23
    Posts
    15,157
    • specs System Specs
      • Motherboard:
        ASUS MAXIMUS ROG HERO X
      • CPU:
        Intel Core i7-8700K 3.7GHz
      • Memory:
        Crucial 2x8GB DDR4 2666 MHz
      • Graphics:
        Gigabyte GTX 1080 G1 Gaming 8 GB
      • Sound Card:
        Asus Xonar DSX
      • Hard Drives:
        WD Caviar Black 1TB SATA III 7200rpm, WD Caviar Black 6TB SATA III 7200rpm
      • Disk Drives:
        Samsung 960 Evo 256GB NVME PCIe
      • Power Supply:
        Corsair HX 750W 80+ Platinum
      • Case:
        Fractal Design Define R6
      • Cooling:
        Noctua NH-D14
      • Display:
        Philips Brilliance BDM4065UC 4K 3840x2160
      • Operating System:
        Windows 10 Pro 1803 x64

    Re: Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    Hi!

    Can you please attempt to uninstall all the language packs except English?
    Koff says thanks for this.


    Users needing assistance: If I haven't replied to your thread within 48 hours, please send me a Personal Message.

    Windows Update Academy Trainees: If I haven't replied to your CMF thread within 24 hours, please send me a Personal Message.

  4. #4

    Join Date
    Nov 2018
    Location
    Germany - Wuppertal
    Posts
    6

    Re: Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    Hi softwaremaniac and thank you for your advice,

    I attempted to uninstall not needed Languagepacks.

    First I looked up what Languagepacks where present with Dism /online /Get-Intl -> fr-FR, ro-RO, kr-KR, de-DE and en-US where listed. I uninstalled fr-FR, ro-RO, kr-KR via Lpksetup.exe /u [languagepack]. I did not uninstall German because the Active Directory is in German and i read that uninstalling the language could cause problems, correct me if this is wrong. Also the errors i found in the cbs log so far always pointed to kr-KR and es-ES Languagepacks. However, after uninstalling these Languagepacks, I tried installing the feature again and there where still errors pointing to a spanish languagepack es-ES. Scince the es-ES language was not listed after the dism command, I tried installing the languagepack via GUI to correctly uninstall it. The language installs fine, but the languagepack cannot be installed. It starts downloading and stops without an error in the gui, then the download button just reappears.

    When triing to install the Feature, I still get the Error 0x800f081f saying that the source files cannot be found.

    I attached the new cbs log:
    HiDrive

    Last things I did where triing to download the spanish Languagepack twice at 10:01 and tried adding the feature at 10:05


    Thank you and have a great day!

    Greetings,
    Koff
    - ​When life gives you lemons, make lemonade -

  5. #5
    Moderator
    BSOD Kernel Dump Analyst
    Windows Update Instructor
    softwaremaniac's Avatar
    Join Date
    Oct 2014
    Location
    Croatia
    Age
    23
    Posts
    15,157
    • specs System Specs
      • Motherboard:
        ASUS MAXIMUS ROG HERO X
      • CPU:
        Intel Core i7-8700K 3.7GHz
      • Memory:
        Crucial 2x8GB DDR4 2666 MHz
      • Graphics:
        Gigabyte GTX 1080 G1 Gaming 8 GB
      • Sound Card:
        Asus Xonar DSX
      • Hard Drives:
        WD Caviar Black 1TB SATA III 7200rpm, WD Caviar Black 6TB SATA III 7200rpm
      • Disk Drives:
        Samsung 960 Evo 256GB NVME PCIe
      • Power Supply:
        Corsair HX 750W 80+ Platinum
      • Case:
        Fractal Design Define R6
      • Cooling:
        Noctua NH-D14
      • Display:
        Philips Brilliance BDM4065UC 4K 3840x2160
      • Operating System:
        Windows 10 Pro 1803 x64

    Re: Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    I am going to need more info:


    Step#1 - Capture Process Monitor Trace
    1. Download and run Process Monitor. Leave this running while you perform the next steps.
    2. Try installing the feature just like you have in the past.
    3. Stop Process Monitor as soon as it fails. You can simply do this by clicking the magnifying glass on the toolbar as shown below.


    4. Select the File menu...Save... and save the file to your desktop. This is likely the default location. The name (unless changed) will be LogFile.PML. This is fine.
    5. Zip up and attach the LogFile.PML file as well as your CBS.log


    Users needing assistance: If I haven't replied to your thread within 48 hours, please send me a Personal Message.

    Windows Update Academy Trainees: If I haven't replied to your CMF thread within 24 hours, please send me a Personal Message.

  6. #6

    Join Date
    Nov 2018
    Location
    Germany - Wuppertal
    Posts
    6

    Re: Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    Good morning Mr. maniac,

    I hope you have a good day so far!

    - Tried to install feature 09:35
    - Tried to install languagepack 11:41

    CBS: HiDrive
    Logfile Feature: HiDrive
    Logfile Languagepack: HiDrive

    Thank you and greetings,
    Koff
    - ​When life gives you lemons, make lemonade -

  7. #7
    Moderator
    BSOD Kernel Dump Analyst
    Windows Update Instructor
    softwaremaniac's Avatar
    Join Date
    Oct 2014
    Location
    Croatia
    Age
    23
    Posts
    15,157
    • specs System Specs
      • Motherboard:
        ASUS MAXIMUS ROG HERO X
      • CPU:
        Intel Core i7-8700K 3.7GHz
      • Memory:
        Crucial 2x8GB DDR4 2666 MHz
      • Graphics:
        Gigabyte GTX 1080 G1 Gaming 8 GB
      • Sound Card:
        Asus Xonar DSX
      • Hard Drives:
        WD Caviar Black 1TB SATA III 7200rpm, WD Caviar Black 6TB SATA III 7200rpm
      • Disk Drives:
        Samsung 960 Evo 256GB NVME PCIe
      • Power Supply:
        Corsair HX 750W 80+ Platinum
      • Case:
        Fractal Design Define R6
      • Cooling:
        Noctua NH-D14
      • Display:
        Philips Brilliance BDM4065UC 4K 3840x2160
      • Operating System:
        Windows 10 Pro 1803 x64

    Re: Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    Just to confirm, what languages are currently listed on the Server?


    Users needing assistance: If I haven't replied to your thread within 48 hours, please send me a Personal Message.

    Windows Update Academy Trainees: If I haven't replied to your CMF thread within 24 hours, please send me a Personal Message.

  8. #8

    Join Date
    Nov 2018
    Location
    Germany - Wuppertal
    Posts
    6

    Re: Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    Hello!

    - In the Windows settings gui -> region and language there is Deutsch (Deutschlang) = German and Espanol (Espana) listed (beneath the spanish language name is stated that a languagepack is available. When I open the options and try to download it, it does not work. The download bar starts, then disappears and the download button reappears)
    - With Dism /online /Get-Intl only de-DE and en-US is shown
    - ​When life gives you lemons, make lemonade -

  9. #9
    Moderator
    BSOD Kernel Dump Analyst
    Windows Update Instructor
    softwaremaniac's Avatar
    Join Date
    Oct 2014
    Location
    Croatia
    Age
    23
    Posts
    15,157
    • specs System Specs
      • Motherboard:
        ASUS MAXIMUS ROG HERO X
      • CPU:
        Intel Core i7-8700K 3.7GHz
      • Memory:
        Crucial 2x8GB DDR4 2666 MHz
      • Graphics:
        Gigabyte GTX 1080 G1 Gaming 8 GB
      • Sound Card:
        Asus Xonar DSX
      • Hard Drives:
        WD Caviar Black 1TB SATA III 7200rpm, WD Caviar Black 6TB SATA III 7200rpm
      • Disk Drives:
        Samsung 960 Evo 256GB NVME PCIe
      • Power Supply:
        Corsair HX 750W 80+ Platinum
      • Case:
        Fractal Design Define R6
      • Cooling:
        Noctua NH-D14
      • Display:
        Philips Brilliance BDM4065UC 4K 3840x2160
      • Operating System:
        Windows 10 Pro 1803 x64

    Re: Fail to install feature & Windows Updates on Server 2016 - languagepack problems?

    I have confirmed that the feature install is failing because of a Spanish components. I say components because I believe there are multiple.


    Users needing assistance: If I haven't replied to your thread within 48 hours, please send me a Personal Message.

    Windows Update Academy Trainees: If I haven't replied to your CMF thread within 24 hours, please send me a Personal Message.

Similar Threads

  1. Replies: 1
    Last Post: 11-01-2018, 11:47 PM
  2. Replies: 11
    Last Post: 10-10-2018, 12:07 PM
  3. Windows server 2016 version 1607 updates failing
    By decara in forum Windows Update
    Replies: 25
    Last Post: 08-24-2018, 04:32 PM
  4. Replies: 11
    Last Post: 08-21-2018, 03:00 PM
  5. Replies: 5
    Last Post: 10-03-2016, 03:12 PM

Log in

Log in