1. #1

    [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    Hi,

    hope I'm right in this category here.

    I have windows7 64bit on a Intel DX58SO2 machine.

    I have recognized that i cannot run the IAStorUi.exe anymore,
    which is from the intel rapidstrorage driver for the sata controller.

    in another intel thread i found someone, who posted, that same problem came to him after netframework update.
    my netwframework works fine 4.61.

    has anybody an idea.

    the last intelrapistorage version for my computer recommended at intel is: STOR_Win7_XP_11.0.0.1032_PV

    should i try to update this?

    thanks for assistance

    cheers mike


    • Ad Bot

      advertising
      Beep.

        
       

  2. #2
    xilolee's Avatar
    Join Date
    Dec 2013
    Location
    World, Europe, Italy
    Posts
    2,266
    • specs System Specs
      • Manufacturer:
        XILOLEE.com
      • Model Number:
        XILO
      • Motherboard:
        ASROCK FM2A88M Pro3+ chipset A88X Bolton-D4
      • CPU:
        A10-7800, 4 CPU, 4 thr, 65/45W, FM2+, 28nm, Steamroller/Kaveri
      • Memory:
        10GB (Nanya and kingston ddr3-1333 9-9-9-24)
      • Graphics:
        Radeon R7 720MHz (8 GPU cores, integrated in CPU)
      • Sound Card:
        RealTek ALC662 (integrated in MB)
      • Hard Drives:
        Seagate ST500DM002-1BD142 500GB 7200RPM
      • Power Supply:
        SuperFlower 450W 80+ Platinum (SF-450P14PE)
      • Case:
        Sharkoon VG4-S
      • Cooling:
        Realtek RTL8111GR (NIC integrated in MB)
      • Display:
        Samsung SyncMaster SA100 LS22A100NS-EN
      • Operating System:
        Windows 10 Home/Standard x64

    Re: [7SP1 x64] IAStoreUI dont't work anymore

    Hi Mike1950r.

    And what's the current version of it?

    By the way, yes: if you have an older version of it, try to update it.

  3. #3

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStoreUI don't work anymore

    Hi xilolee,

    thanks for answering.

    the version is 11.0.0.1032
    downloaded installer at intel for dx58so2
    is: STOR_Win7_XP_11.0.0.1032_PV.exe

    there is no newer update in dx58so2 driver page at intel.

    if i try to update from the intelrapistorage page at intel all tries fail with error messages, "not for this platform".
    one said it needed netframework 4.5 installed.
    i have 4.61 installed, do not know why this should not work downward compatible.

    indeed the only thing not working is clicking on the system panel icon for IAStoreUI options,
    or execute IAStoreUI.exe directly.

    always error message, that program has to be terminated.
    (new install won't help)

    on the other hand the driver:
    (iaStor Intel Rapid Storage Technology driver - x64 (Verified) Intel Corporation c:\windows\system32\drivers\iastor.sys 30.11.2011 04:39)
    works correct for the intel ich10r sata ahci controller.

    strange issue though.

    hope these informations bring some light into.

    cheers mike

  4. #4
    xilolee's Avatar
    Join Date
    Dec 2013
    Location
    World, Europe, Italy
    Posts
    2,266
    • specs System Specs
      • Manufacturer:
        XILOLEE.com
      • Model Number:
        XILO
      • Motherboard:
        ASROCK FM2A88M Pro3+ chipset A88X Bolton-D4
      • CPU:
        A10-7800, 4 CPU, 4 thr, 65/45W, FM2+, 28nm, Steamroller/Kaveri
      • Memory:
        10GB (Nanya and kingston ddr3-1333 9-9-9-24)
      • Graphics:
        Radeon R7 720MHz (8 GPU cores, integrated in CPU)
      • Sound Card:
        RealTek ALC662 (integrated in MB)
      • Hard Drives:
        Seagate ST500DM002-1BD142 500GB 7200RPM
      • Power Supply:
        SuperFlower 450W 80+ Platinum (SF-450P14PE)
      • Case:
        Sharkoon VG4-S
      • Cooling:
        Realtek RTL8111GR (NIC integrated in MB)
      • Display:
        Samsung SyncMaster SA100 LS22A100NS-EN
      • Operating System:
        Windows 10 Home/Standard x64

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore


  5. #5

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    this does not work,
    because higher version is already installed.

    cheers mike

  6. #6
    xilolee's Avatar
    Join Date
    Dec 2013
    Location
    World, Europe, Italy
    Posts
    2,266
    • specs System Specs
      • Manufacturer:
        XILOLEE.com
      • Model Number:
        XILO
      • Motherboard:
        ASROCK FM2A88M Pro3+ chipset A88X Bolton-D4
      • CPU:
        A10-7800, 4 CPU, 4 thr, 65/45W, FM2+, 28nm, Steamroller/Kaveri
      • Memory:
        10GB (Nanya and kingston ddr3-1333 9-9-9-24)
      • Graphics:
        Radeon R7 720MHz (8 GPU cores, integrated in CPU)
      • Sound Card:
        RealTek ALC662 (integrated in MB)
      • Hard Drives:
        Seagate ST500DM002-1BD142 500GB 7200RPM
      • Power Supply:
        SuperFlower 450W 80+ Platinum (SF-450P14PE)
      • Case:
        Sharkoon VG4-S
      • Cooling:
        Realtek RTL8111GR (NIC integrated in MB)
      • Display:
        Samsung SyncMaster SA100 LS22A100NS-EN
      • Operating System:
        Windows 10 Home/Standard x64

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    Uninstall it, then install 4.5.
    Let's see if it works after that.

  7. #7

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    hi,

    no i do not want to touch netframework anymore.
    i had so many troubles, which were resolved in this forum.
    now windows update works without problems.
    i want to leave it like this.

    i have disabled the intelrapistorage service and icon.exe,
    which are not important for me, and kept just the
    iaStor Intel Rapid Storage Technology driver - x64,
    which works fine.

    i have wd diagnostics for verifying the hds.
    this is ok for me.

    thanks for your assistance.

    cheers mike

  8. #8
    jcgriff2's Avatar
    Join Date
    Feb 2012
    Location
    New Jersey Shore
    Posts
    16,591
    • specs System Specs
      • Manufacturer:
        HP
      • Model Number:
        HP ENVY TouchSmart 17-j130us Notebook - E8A04UA
      • Motherboard:
        HP Insyde 720265-501 6050A2549501-MB-A02
      • CPU:
        Intel Core i7-4700MQ Processor with Turbo Boost up to 3.4GHz.
      • Memory:
        12GB DDR3L SDRAM (2 DIMM)
      • Graphics:
        Intel HD graphics 4600 with up to 1792MB total graphics memory
      • Sound Card:
        Beats Audio quad speakers and two subwoofers
      • Hard Drives:
        1TB 5400RPM hard drive with HP ProtectSmart Hard Drive Protection
      • Disk Drives:
        Hitachi 500 GB SSD; 7 TB USB External
      • Power Supply:
        90w
      • Case:
        Laptop
      • Display:
        17.3-inch diagonal HD+ BrightView LED-backlit touchscreen display (1600 x 900)
      • Operating System:
        Windows 8.1

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    Before attempting any additional updates or rollbacks, be sure to create a Windows System Restore point so that you can start again from the beginning if need be -

    Windows System Restore - Create a Restore Point (Windows 10, 8.1, 8, 7 & Vista)

    Regards. . .

    jcgriff2

  9. #9

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    hi jcgriff2,

    thanks for reply.

    ofcourse i always make manual restore points.

    with this rapidstorage packet it's a bit complicate,
    cause not all versions work with the dx58so2.

    for me the most important part is the iaStor Intel Rapid Storage Technology driver.
    the computer works also without,
    but then the different harddisks are not handled in the right order, say hd0, hd1, hd2, hd3 etc.

    this driver works without problems.

    in the packet is also a service, which monitors the sata port and sends notifications, if a problem occurs.
    i think this service is also working without problems, but it is not so important for me.

    the 3rd part in the package is the application "IAStorUI",
    which exists as link in the start-menu and also as icon in the control-panel.

    this application is not working anymore.
    it's for diagnostic purposes and for handling raid drives.

    if i want to start it, i get this error message:
    (translated)
    "IAStorUI" don't work anymore.
    a problem has prohibited the execution of this program.
    close the program.

    my intention for this thread was to find out why this error message comes.

    cheers mike

  10. #10
    plodr's Avatar
    Join Date
    Sep 2016
    Posts
    252

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    I found this
    IAStorUI.exe is loaded in the current user (HKCU) registry as an auto-starting executable named 'Intel Rapid Store' and executes as "C:\Program Files\Intel\Intel(R) Rapid Storage Technology\IAStorUI.exe".
    Source: Intel Rapid Storage Technology - Should I Remove It?

    I'd probably make a backup of the registry if that key exists then go in and remove the key.

    Reboot or cold boot and see if the error is gone. If something seems strange, restore the backup of the registry you made.

  11. #11

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    hi plodr,

    interesting issue, what you report.
    i do not find this entry on my machine, not as shedule not as autoload.
    as autoload i have only
    the service on key:
    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\IAStorDataMgrSvc"
    and
    "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run\IAStorIcon"
    with the value:
    "C:\\Program Files (x86)\\Intel\\Intel(R) Rapid Storage Technology\\IAStorIcon.exe"

    I think it's depending of the package version.

    Anyway removing the whole package is not a good idea as long as you are using AHCI instead of IDE in the BIOS setting,
    cause for AHCI you need the "iaStor Intel Rapid Storage Technology driver".

    you cannot ONLY install the driver,
    you have always the whole package.

    in my case the problem is ONLY with the "IAStorUI.exe", which is not autoloaded.
    (like reported detailed above)

    i think it's a very particular problem of my package build and my machine.

    as long as i get no other solution, or even an idea why this program refuses to run,
    for me the best solution is, just to use the driver.

    i have disabled the service in the package and the autoload program "IAStorIcon.exe",
    cause i did not know if they are also touched by this problem.

    the driver runs fine, and it's the most important for me.

    take care and merry christmas to all

    cheers mike

  12. #12

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    Hi again.

    Finally found a solution:
    I found a version, which works:
    Intel Rapid Storage 11.7.1013

    Installed and all options work.
    The new driver has no service anymore,
    Just an autoload for delay start.

    Just in case somebody needs this info.

    Cheers mike
    plodr says thanks for this.

  13. #13

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    btw.
    the new driver is also with a service.
    just to correct me.

    cheers mike

  14. #14
    xilolee's Avatar
    Join Date
    Dec 2013
    Location
    World, Europe, Italy
    Posts
    2,266
    • specs System Specs
      • Manufacturer:
        XILOLEE.com
      • Model Number:
        XILO
      • Motherboard:
        ASROCK FM2A88M Pro3+ chipset A88X Bolton-D4
      • CPU:
        A10-7800, 4 CPU, 4 thr, 65/45W, FM2+, 28nm, Steamroller/Kaveri
      • Memory:
        10GB (Nanya and kingston ddr3-1333 9-9-9-24)
      • Graphics:
        Radeon R7 720MHz (8 GPU cores, integrated in CPU)
      • Sound Card:
        RealTek ALC662 (integrated in MB)
      • Hard Drives:
        Seagate ST500DM002-1BD142 500GB 7200RPM
      • Power Supply:
        SuperFlower 450W 80+ Platinum (SF-450P14PE)
      • Case:
        Sharkoon VG4-S
      • Cooling:
        Realtek RTL8111GR (NIC integrated in MB)
      • Display:
        Samsung SyncMaster SA100 LS22A100NS-EN
      • Operating System:
        Windows 10 Home/Standard x64

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    Good! You probably intend 11.7.0.1013.
    It does not officially support your board.
    I found on intel forums another guy that used IRST 12.5.0.1066 - May 3 2013 (click) on DX58SO (almost the same board of yours).
    It could be this is the latest version of IRST that you could try for your board: 12.8.0.1016.

  15. #15

    Re: [7SP1 x64] Intel Desktop Board DX58SO2: IAStorUI don't work anymore

    Hi,

    tried 12.8.0.1016
    but it refuses install on my system asking for netframework 4.0
    although i have netframework 4.61 installed.

    i keep on 11.7.0.1013 it's working without problems.

    cheers mike

Similar Threads

  1. [7SP1 x64] BSOD on Ryzen. TEMP FIX: changed ram speed.
    By ldeveraux in forum BSOD, Crashes, Kernel Debugging
    Replies: 65
    Last Post: 02-11-2018, 09:17 PM
  2. Win 10 Tiles not working, Desktop Icons work fine
    By john19303 in forum Windows 10
    Replies: 2
    Last Post: 12-17-2015, 07:20 PM
  3. Replies: 15
    Last Post: 10-23-2015, 02:16 PM
  4. Replies: 2
    Last Post: 05-02-2014, 03:48 PM

Log in

Log in