1. #1

    usb device descriptor request failed on all ports

    Hi All !

    Suddenly when connecting my phone to one of my usb ports, I get the message : usb device descriptor request failed. Before that all was ok and could see all my phones I connected.
    I've tried all methods but to no avail.
    When I connect a mass storage device, it's being recognized though...
    All drivers are up to date.

    Any clue ?

    Thnx !


    • Ad Bot

      advertising
      Beep.

        
       

  2. #2

    Re: usb device descriptor request failed on all ports

    did a factory restore on my phone and all ok now - nothing to do with w10

  3. #3
    Digerati's Avatar
    Join Date
    Aug 2012
    Location
    Nebraska, USA
    Posts
    3,669
    • specs System Specs
      • Manufacturer:
        BrightWorks Systems
      • Model Number:
        BWS-6 E-IV
      • Motherboard:
        Gigabyte GA-Z170-HD3
      • CPU:
        Intel Core i5-6600 Skylake Pushed to 3.9GHz
      • Memory:
        2 X 8GB Corsair Vengeance DDR4 3000
      • Graphics:
        EVGA GeForce GTX 1050TI 04G-P4-6251-KR, 4GB GDDR5
      • Sound Card:
        Integrated
      • Disk Drives:
        Samsung 850 Pro 256GB SSD, 850 EVO 250GB SSD, Blu-ray R/W
      • Power Supply:
        EVGA Supernova 550W Gold
      • Case:
        Fractal Design Define R4 Mid Tower w/Window
      • Cooling:
        2 x 140mm case fans, OEM CPU Cooler
      • Display:
        2 x Samsung S24E650BW 24 inch WS
      • Operating System:
        Windows 10 Pro 64-Bit

    Re: usb device descriptor request failed on all ports

    Thanks for coming back and posting your solution! :)
    Bill (AFE7Ret)
    Freedom is NOT Free!
    MS MVP 2007 - 2018

    Heat is the bane of all electronics!

Similar Threads

  1. [SOLVED] Windows com ports gone missing!
    By JamesAB in forum Windows 7 | Windows Vista
    Replies: 5
    Last Post: 06-10-2015, 12:07 PM
  2. Replies: 2
    Last Post: 07-16-2013, 04:17 PM
  3. All USB ports not working.
    By Mikee in forum General Help & Information
    Replies: 2
    Last Post: 05-20-2013, 05:37 PM
  4. Win 8 Crashes during sleep, deactivates license, kills USB ports
    By Roger Eberhart in forum BSOD, Crashes, Kernel Debugging
    Replies: 9
    Last Post: 02-21-2013, 12:29 AM

Log in

Log in