1. #1
    Adamsavage79's Avatar
    Join Date
    Nov 2017
    Location
    Ottawa
    Posts
    95

    Archer C60 | AC1350 Router issues

    Lately my Archer C60 has been acting up quite abit. It basically will have all the lights on, and look like it's acting normal but that couldn't be further from the truth. I plan to do a factory reset tomorrow, so hopefully that solves it. My question is, will this be a temp fix or will this router start acting up again. The problem is that it will flat out refuse ANY connection to it. I can't even logg into the router on my desktop, and it's hardwired to it. Rebooting the router solves the problem for a day or two, and then it does it again. I don't want to have to reboot the router daily, because it's acting up..

    I might even have to send it back under warranty.


    • Ad Bot

      advertising
      Beep.

        
       

  2. #2
    plodr's Avatar
    Join Date
    Sep 2016
    Posts
    250

    Re: Archer C60 | AC1350 Router issues

    My question is, will this be a temp fix or will this router start acting up again.
    No one can possibly answer that. Only you will be able to determine this after you do a factory reset.

    Page for this router: TP-LINK
    Archer C60 v2.0 Default Password & Login, Manuals and Reset
    Instructions
    | RouterReset

  3. #3
    Adamsavage79's Avatar
    Join Date
    Nov 2017
    Location
    Ottawa
    Posts
    95

    Re: Archer C60 | AC1350 Router issues

    Not even 24 hours after a factory reset, and it's doing the same thing again..

  4. #4
    plodr's Avatar
    Join Date
    Sep 2016
    Posts
    250

    Re: Archer C60 | AC1350 Router issues

    Then I'd send it back under warranty.

    It shouldn't be necessary to keep resetting a router.

    My first router, Linksys WRT54G, worked flawlessly from 2004 through 2017. Not quite 13 years with zero problems.

  5. #5
    Adamsavage79's Avatar
    Join Date
    Nov 2017
    Location
    Ottawa
    Posts
    95

    Re: Archer C60 | AC1350 Router issues

    Those older Linksys routers had quite the range on them for G band, specially when you changed the firmware and boosted the singal.

  6. #6
    plodr's Avatar
    Join Date
    Sep 2016
    Posts
    250

    Re: Archer C60 | AC1350 Router issues

    I updated the firmware once and I never boosted the signal.
    We live in a ranch house - everything on one floor with a basement. I am able to use all devices anywhere in the house, including the basement and the patio outside the living room. (Our living room is in the back of the house facing the woods rather than the street.)

Similar Threads

  1. our router: Gateway for hackers
    By JMH in forum Security News
    Replies: 0
    Last Post: 08-18-2015, 02:53 AM
  2. Can a router be infected with malware?
    By JMH in forum News You Can Use
    Replies: 0
    Last Post: 12-25-2012, 09:04 PM
  3. 5 Ways to Secure Your Wireless Router
    By JMH in forum Security News
    Replies: 0
    Last Post: 09-18-2012, 12:27 AM
  4. Wacom HID Router Driver
    By Wrench97 in forum BSOD, Crashes, Kernel Debugging
    Replies: 4
    Last Post: 08-29-2012, 04:22 AM

Log in

Log in