1. #1

    0xF4 BSOD since January - Windows 7 x64

    Hi all,

    I've been experiencing BSODs almost every week since January, when I installed two new hard discs in my PC (both Western Digital, one Caviar Black, the other Caviar Green). I'm fairly sure this can't be a coincidence, but I don't know how to diagnose the exact problem here. I tried taking apart the system and putting back together again a couple of weeks ago, to try to eliminate any connection issues which might be causing the problem, but had no luck. I've started going through the steps on BSOD How-To for Users - DRAFT, and got to the point where it said to post here.

    I've had a look at the "Blue Screen of Death (BSOD) Posting Instructions", and think I can provide all the requested information, so here goes:

    File Collection App Output + PERFMON: (see attached file, bsod_data.zip)


    • OS - Windows 7 Ultimate, x64
    • Original OS - I had XP on my old PC - I used this installation to upgrade install to Windows 7 Ultimate, but since then I've reinstalled Windows 7 several times with reformatting in between
    • OS is a retail upgrade version of Windows 7 Ultimate
    • Most of the system is from August 2011. Since then, I've upgraded my hard discs (this January), although the system still uses an SSD from August 2011.
    • Reinstalled the OS last in January, following move to new hard discs.




    • CPU - Intel Core i5 2500K, running at default frequency
    • Video Card - ASUS Radeon 6850 HD
    • MotherBoard - Gigabyte P67A-UDP3-B3
    • Power Supply - OCZ Stealth X Stream 2 - 700W




    • System Manufacturer - Me!
    • Desktop computer


    I've already run Memtest86+ overnight - it completed 11 passes with no errors, so from what I can tell it's unlikely to be a memory issue. I'll run driver verification and the WD data lifeguard tool today and let you know how they go.

    Many thanks for any help that you're able to give!
    Ben
    Attached Files Attached Files


    • Ad Bot

      advertising
      Beep.

        
       

  2. #2

    re: 0xF4 BSOD since January - Windows 7 x64

    Hi,

    Both of the attached DMP files are of the CRITICAL_OBJECT_TERMINATION (f4) bug check.

    This indicates that a process or thread crucial to system operation has unexpectedly exited or been terminated.

    If we look further into the dump as I also said above, we see EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error.

    What's an I/O error you may ask? An I/O error is when any hardware device (hard disk, flash drive, etc) cannot perform its basic input/output actions such as reading or copying data. When this is the case with a hard disk itself, or any storage related media, it's mostly due to the device PHYSICALLY failing. Do note that with hard disks, the connections can be faulty as well (i.e the SATA cables from the controller on the board to the hard disk itself).

    DO NOTE: This can also be caused by a driver(s) in inadvertently causing corruption.

    With that said, I'd like to take care of those possibilities first.



    1. AppleCharger.sys is listed and loaded which is the GIGABYTE On/Off Charge driver. See here for details - GIGABYTE ON/OFF Charge

    It's problematic and buggy, so uninstall ASAP. Also uninstall Gigabyte Easy Saver.

    2. In your loaded drivers list, dtsoftbus01.sys is listed which is the Daemon Tools driver. Daemon Tools is a very popular cause of BSOD's in 7/8 based systems. Please uninstall Daemon Tools. Alternative imaging programs are: MagicISO, Power ISO, etc.

    3.
    Remove and replace Norton with Microsoft Security Essentials for temporary troubleshooting purposes as it may very likely be causing conflicts:

    Norton removal - https://support.norton.com/sp/en/us/home/current/solutions/kb20080710133834EN_EndUserProfile_en_us;jsessionid=841A6D40BA6872C47697C6C6B19C8E11.4?entsrc=redirect_pubweb&pvid=f-home

    MSE - Microsoft Security Essentials - Microsoft Windows

    4. If after the above you're still crashing, uninstall EASEUS Todo Backup. I've dealt with it before causing crashes.

    Regards,

    Patrick

  3. #3

    re: 0xF4 BSOD since January - Windows 7 x64

    Thanks for your help Patrick. The crashes typically only happen once or twice a week, so it may be a while before I can verify whether we've succeeded!

    I have removed Gigabyte ON/OFF Charge, but couldn't find a "Gigabyte Easy Saver" on the system. The following Gigabyte programs are still installed:

    • Easy Tune 6
    • AutoGreen
    • Smart 6
    • DES 2
    • @BIOS


    Let me know if any of these aren't critical, and I can uninstall them too. I've also uninstalled Daemon tools and Norton as suggested.

    However, I should note that Daemon Tools, Norton and EaseUS Todo Backup had all been running on my system before the BSODs started for at least 6 months with no issues. I don't think it's them, but will leave Daemon Tools and Norton off for now.

    A couple of new things which have come up/I've remembered since my last post:

    1) I've run Western Digital Data Lifeguard Diagnostic on my data drive (not the system drive, which is an SSD I've had for 2 years). The quick test passed, but 4 hours into the extended test, the test exited with the error "Too many bad sectors". So this could potentially be a cause of the problem.

    2) When I enabled driver verification and rebooted, I tried to log in and the PC blue-screened instantly. From the dump, this seemed to be caused by "gdrv.sys" - I've turned off verification for this driver for now to see if there are other problems, and I've attached a new zip to this post containing all dumps up to this point.

    3) I've just remembered that when installing my data drive, the SATA cable didn't click when I inserted it into the port. The cables usually do click, but, for some reason, even though I pushed it in as hard as I could, on this drive the port didn't quite seem deep enough for the cable.

    I'll run the WD tool for my second hard disc overnight.

    Thanks again,
    Ben
    Attached Files Attached Files

  4. #4

    re: 0xF4 BSOD since January - Windows 7 x64

    the test exited with the error "Too many bad sectors". So this could potentially be a cause of the problem.
    Ouch, not good. Possibly.

    From the dump, this seemed to be caused by "gdrv.sys"
    This is Easy Saver as I mentioned, which may be a part of Easy Tune. Get rid of any/all installed Gigabyte software. It's all unnecessary bloatware.

    Ensure the SSD firmware is 100% up to date as well.

    Regards,

    Patrick

Similar Threads

  1. [SOLVED] BSOD 0xF4 Help - Windows 7 x64
    By Damke in forum BSOD, Crashes, Kernel Debugging
    Replies: 9
    Last Post: 03-20-2014, 04:42 PM
  2. Replies: 0
    Last Post: 01-27-2014, 01:32 AM
  3. Microsoft Windows 8.2 Scheduled For January 2014
    By JMH in forum Microsoft News
    Replies: 0
    Last Post: 11-21-2013, 06:51 PM
  4. More BSODs YAY! (0xF4, 0x109, 0x1A)
    By Cl0ttERS in forum BSOD, Crashes, Kernel Debugging
    Replies: 20
    Last Post: 11-17-2012, 12:45 AM
  5. 0xf4 BSOD occurr about every 2 weeks
    By c7c4c7 in forum BSOD, Crashes, Kernel Debugging
    Replies: 3
    Last Post: 10-21-2012, 08:36 PM

Log in

Log in